Cleanup PartDownloader

Unabbreviate "transform" to "transformationMatrix"

Cleanup colors.cpp/.h

Refactor GuiUtilities

Some cleanup

Draw line lengths to 2 decimal points only.

Dropped Qt 4 support. We're Qt 5 only now.

Fixed compilation.

Added doxygen.ini

Moved matrix into new source/header pair in types/

Replaced the ugly for_enum macro with a generator class

Further improved enum handling

Enum stuff

- Refactoring...

Unabbreviated overlay member names

removed removeDuplicates in favor of QSet, and the unused ObjectList class

Fixed circle mode not building the circle anymore

Removed unneeded includes from main.cpp

Moved PreferredLicenseText into HierarchyElement and made the config pointer be passed to LDPaths. Now I can finally remove the Config global pointer.

Moved LDObject::moveObjects into MoveToolset

Rename Pi to lowercase pi

Renamed ldObjectMath.cpp/.h to mathfunctions.cpp/.h

Moved rotation point handling to ldObjectMath.cpp and encapsulated it into new class MathFunctions

Split grid stuff into a new class Grid in grid.cpp/grid.h

Use a better gcd algorithm, some style fixes

Replaced GetRecursiveFilenames with QDirIterator

Reformatted primitives.cpp

Split PrimitivePrompt into its new source files, renamed it to GeneratePrimitivePrompt

(0) -1000 -300 -100 -50 -28 +28 +50 +100 +300 tip

mercurial