CMakeLists.txt

changeset 253
8b994c917f69
parent 252
da4876bfd822
child 256
c6f5de03dc0f
--- a/CMakeLists.txt	Wed Jun 22 20:27:53 2022 +0300
+++ b/CMakeLists.txt	Wed Jun 22 21:42:10 2022 +0300
@@ -20,22 +20,7 @@
 include_directories(${GLM_INCLUDE_DIR})
 add_definitions(-DQT_NO_KEYWORDS)
 source_group("LDForge" REGULAR_EXPRESSION "src/.+\\.(cpp|h|ui)")
-
-qt5_wrap_ui(LDFORGEWIDGETS_FORMS
-	widgets/vec3editor.ui
-	widgets/multiplyfactordialog.ui
-	widgets/matrixeditor.ui
-)
-add_library(ldforgewidgets STATIC
-	widgets/matrixeditor.cpp
-	widgets/matrixeditor.h
-	widgets/vec3editor.cpp
-	widgets/vec3editor.h
-	widgets/multiplyfactordialog.cpp
-	widgets/multiplyfactordialog.h
-	${LDFORGEWIDGETS_FORMS}
-)
-target_link_libraries(ldforgewidgets Qt5::Widgets)
+add_subdirectory(widgets)
 
 set (LDFORGE_SOURCES
 	src/colors.cpp
@@ -69,7 +54,6 @@
 	src/widgets/colorbutton.cpp
 	src/widgets/colorindexinput.cpp
 	src/widgets/colorselectdialog.cpp
-	src/widgets/doublespinbox.cpp
 )
 set (LDFORGE_HEADERS
 	src/basics.h
@@ -110,7 +94,6 @@
 	src/widgets/colorbutton.h
 	src/widgets/colorindexinput.h
 	src/widgets/colorselectdialog.h
-	src/widgets/doublespinbox.h
 )
 set (LDFORGE_FORMS
 	src/mainwindow.ui

mercurial