CMakeLists.txt

changeset 114
4e03b0e2a29f
parent 112
5760cbb32bc0
child 117
121a40d5e34c
--- a/CMakeLists.txt	Mon Jul 26 11:50:45 2021 +0300
+++ b/CMakeLists.txt	Tue Jul 27 09:56:06 2021 +0300
@@ -212,6 +212,15 @@
 set_source_files_properties (${CMAKE_BINARY_DIR}/configuration.cpp PROPERTIES GENERATED TRUE)
 set_property(SOURCE configuration.cpp PROPERTY SKIP_AUTOGEN ON)
 
+
+add_custom_target(linelength ALL
+	COMMAND python3
+		"${CMAKE_SOURCE_DIR}/tools/linelength.py"
+		${LDFORGE_SOURCES}
+		${LDFORGE_HEADERS}
+	WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+add_dependencies(ldforge linelength)
+
 # Collect the current hg revision into hginfo.h
 add_custom_target(revision_check ALL
 	COMMAND python3 "${CMAKE_SOURCE_DIR}/tools/updaterevision.py" --cwd "$(CMAKE_SOURCE_DIR)" hginfo.h

mercurial