CMakeLists.txt

changeset 1017
fc1c13db9618
parent 1015
92c6ec099075
child 1019
a2e4286adb0d
--- a/CMakeLists.txt	Sat Feb 13 04:14:43 2016 +0200
+++ b/CMakeLists.txt	Sun Feb 14 03:19:28 2016 +0200
@@ -29,7 +29,7 @@
 
 include_directories (${QT_INCLUDES} ${CMAKE_CURRENT_BINARY_DIR})
 
-set_source_files_properties (${CMAKE_BINARY_DIR}/configurationvaluebag.cpp PROPERTIES GENERATED TRUE)
+set_source_files_properties (${CMAKE_BINARY_DIR}/configuration.cpp PROPERTIES GENERATED TRUE)
 
 set (LDFORGE_SOURCES
 	src/addObjectDialog.cpp
@@ -112,6 +112,7 @@
 	src/primitives.h
 	src/radioGroup.h
 	src/ringFinder.h
+	src/transform.h
 	src/dialogs/colorselector.h
 	src/dialogs/configdialog.h
 	src/dialogs/ldrawpathdialog.h
@@ -193,13 +194,13 @@
 	qt5_wrap_ui (LDFORGE_FORMS_HEADERS ${LDFORGE_FORMS})
 	add_executable (ldforge WIN32 ${LDFORGE_SOURCES} ${LDFORGE_HEADERS}
 		${LDFORGE_QRC} ${LDFORGE_FORMS_HEADERS}
-		${CMAKE_BINARY_DIR}/configurationvaluebag.cpp)
+		${CMAKE_BINARY_DIR}/configuration.cpp)
 else()
 	qt4_wrap_ui (LDFORGE_FORMS_HEADERS ${LDFORGE_FORMS})
 	qt4_add_resources (LDFORGE_RCC ${LDFORGE_RESOURCES})
 	add_executable (ldforge WIN32 ${LDFORGE_SOURCES} ${LDFORGE_RCC}
 		${LDFORGE_FORMS_HEADERS} ${LDFORGE_HEADERS}
-		${CMAKE_BINARY_DIR}/configurationvaluebag.cpp)
+		${CMAKE_BINARY_DIR}/configuration.cpp)
 endif()
 
 set_source_files_properties (${LDFORGE_HEADERS} PROPERTIES HEADER_FILE_ONLY TRUE)
@@ -220,8 +221,8 @@
 add_custom_target (config_collection ALL
 	COMMAND python
 		"${CMAKE_SOURCE_DIR}/tools/configcollector.py"
-		--header ${CMAKE_BINARY_DIR}/configurationvaluebag.h
-		--source ${CMAKE_BINARY_DIR}/configurationvaluebag.cpp
+		--header ${CMAKE_BINARY_DIR}/configuration.h
+		--source ${CMAKE_BINARY_DIR}/configuration.cpp
 		--sourcedir ${CMAKE_SOURCE_DIR}/src
 		${LDFORGE_SOURCES}
 	WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})

mercurial