CMakeLists.txt

changeset 1391
5fa4bf1fc781
parent 1390
3eace926af7f
child 1392
0541d9b21968
--- a/CMakeLists.txt	Wed May 30 22:31:06 2018 +0300
+++ b/CMakeLists.txt	Mon Jun 04 23:12:40 2018 +0300
@@ -79,6 +79,7 @@
 	src/geometry/plane.cpp
 	src/linetypes/comment.cpp
 	src/linetypes/conditionaledge.cpp
+	src/linetypes/cylinder.cpp
 	src/linetypes/edgeline.cpp
 	src/linetypes/empty.cpp
 	src/linetypes/modelobject.cpp
@@ -96,6 +97,7 @@
 	src/types/vertex.cpp
 	src/widgets/doublespinbox.cpp
 	src/widgets/headeredit.cpp
+	src/widgets/matrixeditor.cpp
 	src/widgets/vertexobjecteditor.cpp
 )
 
@@ -157,6 +159,7 @@
 	src/geometry/plane.h
 	src/linetypes/comment.h
 	src/linetypes/conditionaledge.h
+	src/linetypes/cylinder.h
 	src/linetypes/edgeline.h
 	src/linetypes/empty.h
 	src/linetypes/modelobject.h
@@ -175,6 +178,7 @@
 	src/types/vertex.h
 	src/widgets/doublespinbox.h
 	src/widgets/headeredit.h
+	src/widgets/matrixeditor.h
 	src/widgets/vertexobjecteditor.h
 )
 
@@ -202,6 +206,7 @@
 	src/partdownloader.ui
 	src/widgets/vertexobjecteditor.ui
 	src/widgets/headeredit.ui
+	src/widgets/matrixeditor.ui
 )
 
 set (LDFORGE_OTHER_FILES
@@ -234,6 +239,7 @@
 	if ("${CMAKE_BUILD_TYPE}" STREQUAL "Debug" OR "${CMAKE_BUILD_TYPE}" STREQUAL "RelWithDebInfo")
 		set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DDEBUG")
 	endif()
+	set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -W -Wall -Wpedantic -Werror=switch")
 endif()
 
 qt5_add_resources (LDFORGE_QRC ${LDFORGE_RESOURCES})

mercurial