CMakeLists.txt

changeset 119
bdf8d46c145f
parent 109
6572803cd0ca
child 120
5ea0faefa82a
--- a/CMakeLists.txt	Sun Mar 30 21:35:06 2014 +0300
+++ b/CMakeLists.txt	Sun Mar 30 21:51:23 2014 +0300
@@ -1,37 +1,37 @@
 cmake_minimum_required (VERSION 2.8)
 
 set (BOTC_HEADERS
-	src/BotStuff.h
-	src/Commands.h
-	src/Containers.h
-	src/DataBuffer.h
-	src/Events.h
-	src/Expression.h
-	src/Format.h
-	src/Lexer.h
-	src/LexerScanner.h
-	src/Macros.h
-	src/Main.h
-	src/Parser.h
-	src/Property.h
-	src/String.h
-	src/StringTable.h
-	src/Tokens.h
-	src/Types.h
+	src/botStuff.h
+	src/commands.h
+	src/list.h
+	src/dataBuffer.h
+	src/events.h
+	src/expression.h
+	src/format.h
+	src/lexer.h
+	src/lexerScanner.h
+	src/macros.h
+	src/main.h
+	src/parser.h
+	src/property.h
+	src/string.h
+	src/stringTable.h
+	src/tokens.h
+	src/types.h
 )
 
 set (BOTC_SOURCES
-	src/Commands.cc
-	src/DataBuffer.cc
-	src/Events.cc
-	src/Expression.cc
-	src/Format.cc
-	src/Lexer.cc
-	src/LexerScanner.cc
-	src/Main.cc
-	src/Parser.cc
-	src/String.cc
-	src/StringTable.cc
+	src/commands.cpp
+	src/dataBuffer.cpp
+	src/events.cpp
+	src/expression.cpp
+	src/format.cpp
+	src/lexer.cpp
+	src/lexerScanner.cpp
+	src/main.cpp
+	src/parser.cpp
+	src/string.cpp
+	src/stringTable.cpp
 )
 
 add_subdirectory (updaterevision)
@@ -40,14 +40,14 @@
 get_target_property (UPDATEREVISION_EXE updaterevision LOCATION)
 
 add_custom_target (revision_check ALL
-    COMMAND ${UPDATEREVISION_EXE} src/GitInformation.h
+    COMMAND ${UPDATEREVISION_EXE} src/gitinfo.h
     WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
     DEPENDS updaterevision)
 
 get_target_property (NAMEDENUMS_EXE namedenums LOCATION)
 
 add_custom_target (botc_enum_strings ALL
-    COMMAND ${NAMEDENUMS_EXE} ${BOTC_HEADERS} src/EnumStrings.h
+    COMMAND ${NAMEDENUMS_EXE} ${BOTC_HEADERS} src/enumStrings.h
     WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
     DEPENDS namedenums)
 
@@ -57,4 +57,4 @@
 
 if ("${CMAKE_BUILD_TYPE}" STREQUAL "Debug")
 	set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DDEBUG")
-endif()
\ No newline at end of file
+endif()

mercurial